Facebook Instagram Twitter LinkedIn Google Plus Flickr Pinterest Save Ringgit | The Best Online Shopping Deals, Coupons & Freebies

The vulnerability, which Cisco disclosed on Monday, could allow an attacker to cause a reload, execute arbitrary code, or take full control of an affected system.

 

 

A critical vulnerability affecting the VPNfeature of Cisco's Adaptive Security Appliance software could allow an attacker to cause a reload, execute arbitrary code, or take full control of an affected system.

"The vulnerability is due to an attempt to double free a region of memory when the webvpn feature is enabled on the Cisco ASA device," Cisco wrote in its alert. "An attacker could exploit this vulnerability by sending multiple, crafted XML packets to a webvpn-configured interface on the affected system."

 

WebVPN lets remote users securely access enterprise resources like internal websites, web-enabled applications, email, and more via a web browser. The flaw, which was discovered by Cedric Halbronn from the NCC Group and which Cisco disclosed on Monday, is rated 10 out of 10 in severity.

On the bright side, Cisco said it's not currently aware of any attacks leveraging this flaw, but don't bet on that being the case for too long. The company released free software updates that address the vulnerability; there are no workarounds to fix it. Those without a current Cisco service will need to contact Cisco's Technical Assistance Center to obtain the fix.

A number of Cisco products include the vulnerable software, and are thus at risk, including: 3000 Series Industrial Security Appliance (ISA), ASA 5500 Series Adaptive Security Appliances, ASA 5500-X Series Next-Generation Firewalls, ASA Services Module for Cisco Catalyst 6500 Series Switches and Cisco 7600 Series Routers, ASA 1000V Cloud Firewall, Adaptive Security Virtual Appliance (ASAv), Firepower 2100 Series Security Appliance, Firepower 4110 Security Appliance, Firepower 9300 ASA Security Module, and Firepower Threat Defense Software (FTD).

 Live Chat